Toro snowblower magneto coil repair



Buy universal ignition module HERE — https://amzn.to/1yuvf4S
Buy line clamp set HERE — https://amzn.to/166rqLG

In this video I’m going to continue to work on a Toro snowblower model CCR 2000 e also known as model number 38185. This model is the one that has a 4.5 horse power Suzuki 2 stroke engine. It also has an electric start. It’s a 20-inch path. And a
single stage. Although the repair that I’m showing is on this model you’ll find a lot of similarities when working on other brands of snow blowers such as MTD, cub cadet,simplicity, ariens and craftsmen just to name a few. I show a universal ignition module
that’s being used to replace the factory module that had failed so I’m including the link above for that module also I have a link for the line clamp set that I used to shut off the fuel. When you remove the housings off of the snow blower that keeps the engine protected everything inside is pretty accessible and it’s not very difficult to work on. even though you might be a bit intimidated it’s not a hard task as long as you remember where everything goes once you take it apart. This repair started as a broken recoil rope which I show in another video how to replace that and the reason that it broke not only because it was old but the owner had to pull on it constantly as she was trying to get it to start not realizing that his coil or Magneto was in the process of failing. So I hope this video helps you out, enjoy, and thanks for watching.

source

(7)

2 thoughts on “Toro snowblower magneto coil repair

  1. Hello I am looking for a magneto for the Toro CCR2000 like the one in your video. I have a similar problem. Where did you get the magneto?

  2. Wish you would have showed your coil testing. A lot of people have coil problems on these snowblowers. Did yo just pull the rope with the plug out and grounded and saw the spark was missing? Mine is a 2010 model. Could it be the internal other part of the coil under the epoxy that went bad? Someone said they dug out the epoxy and connected the universal thing to that internal connection and it worked, meaning the coil itself was OK but the internal component was bad. Hope you followed all this rambling.

Leave a Reply

Your email address will not be published. Required fields are marked *